AnsweredAssumed Answered

Webapp wont load in Explorer11 unless I use InPrivate mode

Question asked by cpeters01 on Jun 9, 2016
Latest reply on Jun 10, 2016 by cpeters01

I don't know if this is an anomaly with my browser but I cannot get the Webapp to load up in a regular version of Explorer11. I am on version 11.0.31 and am running Win8. When I do an Inspect element, the debugger says Access denied after running this script:

 

var r=t["default"].Service.extend(a["default"],{util:t["default"].inject.service(),url:t["default"].inject.service(),dependencyService:t["default"].inject.service("dependency"),appId:parseInt(localStorage.getItem("setting.appId"),10),endpointId:localStorage.getItem("setting.endpointId"),nodeHost:localStorage.getItem("setting.nodeHost"),lastEmail:localStorage.getItem("setting.lastEmail"),lastToken:localStorage.getItem("setting.lastToken"),betaMode:localStorage.getItem("setting.betaMode"),jwt:localStorage.getItem("setting.jwt"),doNotDisturb:!1,reacquireStreamInterval:1e3,savedExtension:localStorage.getItem("setting.savedExtension"),forcedNodeIp:localStorage.getItem("setting.forcedNodeIp"),features:{},browserSupport:{},guestOnly:{},development:!1,pluginVersion:"1.0.8",pluginDownloadUris:{safari:"https://cdn.lifesizecloud.com/plugins/1.0.8/LSWebRTCPlugin.dmg",IE:"https://cdn.lifesizecloud.com/plugins/1.0.8/LSWebRTCPlugin.msi"},trialUri:"https://www.lifesize.com/en/solutions/cloud/trial",downloadUri:function(){return"https://manage."+this.get("url").getDomain()+"/#/download"}.property(),manageUri:function(){return"https://manage."+this.get("url").getDomain()}.property(),proxyServiceUri:function(){return"wss://nucleusproxyeast."+this.get("url").getDomain()}.property(),proxyServiceRealm:"lifesize",_onEmailChange:function(){var e=this.get("lastEmail");e&&localStorage.setItem("setting.lastEmail",e)}.observes("lastEmail").on("init"),_onJwtChange:function(){var e=this.get("jwt");localStorage.setItem("setting.jwt",e)}.observes("jwt").on("init"),_onTokenChange:function(){var e=this.get("lastToken");e&&localStorage.setItem("setting.lastToken",e)}.observes("lastToken").on("init"),_onModeChange:function(){var e=this.get("betaMode");localStorage.setItem("setting.betaMode",e)}.observes("betaMode").on("init"),_onExtensionChange:function(){localStorage.setItem("setting.savedExtension",this.get("savedExtension"))}.observes("savedExtension").on("init"),init:function(){this._super(),this._initAppIdentifiers(),this._initToggles("features","feature","features"),this._initToggles("browserSupport","browser","browserSupport"),this._initToggles("guestOnly","browser.guestOnly","guestOnly")},_initAppIdentifiers:function(){this.get("appId")||this.createAppId(),this.get("endpointId")||this.createEndpointId()},saveNodeHost:function(e){this.set("nodeHost",e),localStorage.setItem("setting.nodeHost",e)},createAppIdentifiers:function(){this.createAppId(),this.createEndpointId()},createAppId:function(){var e=1e3*(new Date).valueOf()+Math.floor(1e3*Math.random());this.set("appId",e),localStorage.setItem("setting.appId",e)},createEndpointId:function(){this.get("util")&&(this.set("endpointId",this.get("util").generateUuid()),localStorage.setItem("setting.endpointId",this.get("endpointId")))},_initToggles:function(e,a,r){var i=this,l=t["default"].get(n["default"],"APP."+e);if(!l)return void this.logger.warn("Could not find ENV.APP."+e);var o={};Object.keys(l).forEach(function(e){var t=localStorage.getItem(a+"."+e);t?i.logger.info("Found override "+t+" for "+r+" "+e):t=l[e].toString(),"true"===t||"false"===t?o[e]="true"===t:i.logger.warn(r+" toggle not a boolean; will not override value")}),this.toggleByDependencies(o),this.logger.info(r+" toggles: "+JSON.stringify(o,null,2)),this.set(r,o)},toggleByDependencies:function(e){var t=this;Object.keys(e).forEach(function(n){var a=t.get("dependencyService").getDependencies(n);a&&(t.logger.info(n+" dependencies: "+JSON.stringify(a,null,2)),e[n]&&a.forEach(function(a){e[a]||(t.logger.warn(n+" disabled because it depends on "+a),e[n]=!1)}))})}});e["default"]=r}),define

 

And the Console gives me this warning:

 

Warning: It looks like you're using a minified copy of the development build of React. When deploying React apps to production, make sure to use the production build which skips development warnings and is faster. See https://fb.me/react-minification for more details.

 

If I go to the InPrivate mode of Explorer11 it works just fine. What is going on? Any ideas?

Outcomes