AnsweredAssumed Answered

How do I integrate voice calling with Skype for Business On-Premises?

Question asked by lifetimeuser2007 on Nov 20, 2017
Latest reply on Dec 5, 2017 by lifetimeuser2007

Hello, I have a need to make outgoing phone calls from our Icon 600 with Phone HD. I have Microsoft Lync / Skype for Business (S4B) 2013 installed on-premises. I recently came across this article on the Lifesize Community: 

NOW AVAILABLE: Voice calling with Skype for Business On-Premises 

 

I have spent a few hours trying to get to the Icon to register with our Lync server and I also contacted Lifesize support however they were not able to provide a fix or answer most questions (the service was great though, I just think there are not many people with the same issue, thus lack of information).  

 

I will provide some information about my infrastructure and unsuccessful testing (I have been exporting the Icon logs during failed register attempts).   I also have some questions about the official instructions above. 

 

I have a Session Border Controller (SBC) connected to Intelepeer (our SIP provider).  The SBC connects to our Lync Mediation server.  We have a front-end pool and a load balancer with a virtual IP that distributes the load across the pool. I checked and verified all of the required DNS entries for Lync including the SRV record(s). (sip.domain.com sipinternal.domain.com pool.domain.com and so on).

 

I have many enterprise voice enabled clients.  The SIP account and username I am using for testing with Lifesize is enabled for enterprise voice.  

 

Just FYI, I have legacy Polycom equipment connected to our Lync 2013 server using the Lync interop license.  I connect the Polycom via SIP settings in the network configuration area. 

I am including the sign-in settings I use on Polycom as this will lead into the questions I have about the Lifesize instructions:

Enable SIP: yes

Registration status: registered

SIP server configuration: Auto

BFCP transport preference: Prefer UDP

Sign-in address: user@domain.com

username: domain\username

password: password

proxy server: [BLANK]

Registrar server type: Microsoft

Also, in Admin Settings > Security > Global Security > Encryption > Require AES Encryption for
Calls and ensure that When Available is selected.

 

Now back to Lifesize configuration:

 

Current Build Version: LS_RM3_3.4.0 (2268)
Current Build Date: Mon Aug 28 07:08:05 CDT 2017

 

In Preferences > Network > DNS

The DNS server is the internal IP of my domain.com DNS server (this is where the Lync DNS records are stored). 

I added DNS Domain: domain.com

and Search Domains: domain.com

 

In Preferences > SIP Registrar 2

Use SIP: checked

SIP Server Type: I experimented with all 3 options but all fail when registering (Microsoft Skype for Business, Microsoft Skype for Business (Manual), and Auto)

 

During all failed register attempts I export the logs, unpack the GZ file, and inspect the logs in notepad.  

 

From the logs, when choosing Microsoft Skype for Business or Microsoft Skype for Business (Manual) it seems the Icon can't determine the IP for the SIP server and it attempts to register with itself on the loopback IP address. 


The IP of the Icon 600 is 10.19.1.7

The IP of sip.domain.com is 10.10.0.120

sipinternal.domain.com is 10.10.0.120

pool.domain.com is 10.10.0.120

 

SignalingServer: {SIPA:SipAppUtils.c:268:D}-1:SIPIsIPAddress(), detected is an IPv4 Address
2SignalingServer: {SIPA:SipAppUtils.c:268:D}-1:SIPIsIPAddress(), detected is an IPv4 Address
SignalingServer: {SIPA:SipAppUtils.c:412:D}-1:SIPDomainToIP(),From:127.0.0.1 To:127.0.0.1
SignalingServer: {SIPA:SipAppUtils.c:268:D}-1:SIPIsIPAddress(), detected is an IPv4 Address

{COMM:SipAppMcuComm.cpp:1659:I}-1:McuIfcDetermineNATAddr,Destination is self or loopback ip not using nat address

{SIPA:SipAppEvHandler.c:2100:I}-1:Sending message  To: 127.0.0.1:5074

SIPA:SipAppEvHandler.c:2214:I}-1:Incoming message  From: 10.19.1.7:5074  

 

This above is the same result even when I choose Microsoft Skype for Business (Manual) and enter the internal and external Lync server hostnames or IP.  I see in the logs where it enters my internal and external hostname or IP in the DB, but then it attempts to connect to 127.0.0.1

 

However if I choose SIP Server Type: Auto, and enter "Register Hostname: sip", the register will still fail, but the logs show it actually resolved the correct IP of our Lync SIP server.   

 

{SIPA:SipAppUtils.c:273:D}-1:SIPIsIPAddress(), detected is NOT an IPAddress
{SIPA:SipAppUtils.c:273:D}-1:SIPIsIPAddress(), detected is NOT an IPAddress
{SIPA:SipAppUtils.c:412:D}-1:SIPDomainToIP(),From:sip.domain.com To:10.10.0.120
{SIPA:SipAppUtils.c:268:D}-1:SIPIsIPAddress(), detected is an IPv4 Address

 

When using Auto, the Icon seems to attempt to connect to a port that Lync doesn't support. I assume Auto is meant for devices like ShoreTel and others. 

 

My final question is about the official instructions for connecting Lifesize to S4B on Premises.

  • SIP username – the registered SIP username for the device
  • Authorization Username – username authorized to access the SIP system

 

What are examples of proper syntax for SIP username and Authorization username?  If I use the above Polycom settings as an example, I would have to assume:

SIP username: user@domain.com

Authorization Username: domain\user.

 

Has anybody successfully connected their Lifesize to Lync/S4B on premises?

 

Thanks for reading and for any suggestions.

 

Mike

Outcomes